Select Page

While AcuCharting may work on older models, we recommend and iPad 2 or newer for best performance.  We support iOS7 and above.